1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

engine misfires

Discussion in 'Norton Commando Motorcycles (Classic)' started by Anonymous, Sep 28, 2003.

  1. Anonymous

    Anonymous Guest

    Hi I am having difficulty correcting a problem with my 68 750 commando it starts ok and idel is not bad but could be better the problem is at around 3000rpm the engine misfires and will not except more throttle. If I slowly roll the throttle on engine is ok up to 3000rpm then begins to misfire if I quickly open throttle the engine will quit unless I release throttle and return to idel.I have a rita ign with 6volt coils with 2.4 ohms each the rita is sparking and has around 300 ohms resistance when checked at pickup.I'm thinking timing however I have discovered somewhat of a problem there. I did not install the electronic ign and when checking timing marks on rotor found a punch mark on rotor lines up at 28degrees not the orginal mark. This did not make sense to me so I removed valve covers and confirmed when cyl was on compression stroke then checked mark again to discover the punch mark instead of orginal timing mark why is this I am not sure the rotor is keyed on and can only fit 2 ways mark inside{wrong} or timing mark facing out{correct} So why the extra marks. Could this bike have the wrong rotor? and this is why the punch mark was used. What a mess. Believe it or not the bike was running great untill now. Frustrated
     

Share This Page