SCS Delta 400 Users Group

Joined
Jan 16, 2015
Messages
3,362
Country flag
Hello , All SCS Delta 400 users ! I am now a member of this growing community. I just put in my new ECU today and now I see what Claudio is saying " Impressive" . The idle is better for sure and after 4000 RPMs it comes on with an anger I have not known before ! Seat of the pants dyno says more for sure , very nice. The SC Typhoon was working OK for me , and I will keep it as a back up spare . Things I found so far using SXTune :
1. Throttle position is now in % not volts . This was the only adjustment I had to make (throttle set screw) , my previous setting was 1.4 % with the Typhoon and the Delta 400 is now set to 0 to .4 % flashing.
2. My side stand switch needs to be up ready to ride (not down parked) to start. I have not found the setting for this or maybe the ECU doesn't know I am in N neutral . Either way , I will get to the bottom of it email SCS Delta UK or maybe one of you more experienced Delta 400 users can let me know.
3. I will post all the changes like fuel consumption and everything else I can think of . I don't see the Typhoon going back in ever !
 
Last edited:

Claudio

VIP MEMBER
Joined
Dec 3, 2018
Messages
85
Country flag
Tony, I'm glad you are satisfied with the new CPU.
I had the initial problem that the bike did not start and with the assistance of Simon from SCS I disabled the tilt sensor.
From previous experience I have seen that the tilt sensor did not work even with the CPU Typhoon.
Yesterday I saw that the side stand is not in safety, but I think I know where to intervene with SXTune.
When I have resolved I will publish the procedure.
Saturday I had a beautiful race with a tip at 180 Km / h and I confirm that the bike is doing very well.
 

cliffa

VIP MEMBER
Joined
May 26, 2013
Messages
1,479
Country flag
Like your NATO ZULU watch strap ;) what's one the other side Tony?

Oh, and the Delta 400 isn't bad either. Big beast though isn't it? or is that just the camera ?
 
Joined
Jan 16, 2015
Messages
3,362
Country flag
Tony, I'm glad you are satisfied with the new CPU.
I had the initial problem that the bike did not start and with the assistance of Simon from SCS I disabled the tilt sensor.
From previous experience I have seen that the tilt sensor did not work even with the CPU Typhoon.
Yesterday I saw that the side stand is not in safety, but I think I know where to intervene with SXTune.
When I have resolved I will publish the procedure.
Saturday I had a beautiful race with a tip at 180 Km / h and I confirm that the bike is doing very well.
Thanks , that would be helpful .
 

Claudio

VIP MEMBER
Joined
Dec 3, 2018
Messages
85
Country flag
Thanks , that would be helpful .
I contacted SCS and they confirm the problem of the lack of safety of the stand.
The engineer who takes care of it is on vacation and as soon as he returns he will give me a solution
 
Joined
Jan 16, 2015
Messages
3,362
Country flag
I contacted SCS and they confirm the problem of the lack of safety of the stand.
The engineer who takes care of it is on vacation and as soon as he returns he will give me a solution
Hello Claudio , If you leave A31 (inputs cofiguration) set to Tilt Switch , this will shut down the engine when the side stand is deployed. The problem is you can't start your bike with the side stand down . So , what I am doing in the meantime is : Start my bike on the paddock stand with the side stand up and let it warm while I get my riding gear on. And you know the rest. Next project : Increase of the Rev Limiter to 7,900 RPM .
 

Claudio

VIP MEMBER
Joined
Dec 3, 2018
Messages
85
Country flag
hi Tony
SCS told me that the tilt sensor is on the A31 tilt switch, but I want to check.
thanks for the information
 
Joined
Jan 16, 2015
Messages
3,362
Country flag
hi Tony
SCS told me that the tilt sensor is on the A31 tilt switch, but I want to check.
thanks for the information
Hello Claudio , The A31 selection is set to Tilt Switch . The side stand switch is what is actually wired to pin A31 .
Pin 33 has the actual Tip Over switch going to it. This is not programmed either and does not work . I have reported this to Matt also.
 
Last edited:

Stephen_Spencer

VIP MEMBER
Joined
May 31, 2017
Messages
346
Country flag
Hello Claudio , If you leave A31 (inputs cofiguration) set to Tilt Switch , this will shut down the engine when the side stand is deployed. The problem is you can't start your bike with the side stand down . So , what I am doing in the meantime is : Start my bike on the paddock stand with the side stand up and let it warm while I get my riding gear on. And you know the rest. Next project : Increase of the Rev Limiter to 7,900 RPM .
May I ask why increase the rev limiter Tony, there’s nothing happening except more noise anywhere near the current rev limiter?
 

Claudio

VIP MEMBER
Joined
Dec 3, 2018
Messages
85
Country flag
Hello Claudio , The A31 selection is set to Tilt Switch . The side stand switch is what is actually wired to pin A31 .
Pin 33 has the actual Tip Over switch going to it. This is not programmed either and does not work . I have reported this to Matt also.
Hi Tony
Can I ask you on which SXTune page you find the pin 33 setup?
Thank you
 

Claudio

VIP MEMBER
Joined
Dec 3, 2018
Messages
85
Country flag
Hello Claudio , If you leave A31 (inputs cofiguration) set to Tilt Switch , this will shut down the engine when the side stand is deployed. The problem is you can't start your bike with the side stand down . So , what I am doing in the meantime is : Start my bike on the paddock stand with the side stand up and let it warm while I get my riding gear on. And you know the rest. Next project : Increase of the Rev Limiter to 7,900 RPM .
The map on the CPU Typhoon has A31 set on "gear cut sw reverse"
I have to try the setup on Delta 400 and check the side stand
 
Joined
Jan 16, 2015
Messages
3,362
Country flag
Hi Tony
Can I ask you on which SXTune page you find the pin 33 setup?
Thank you
It is not labeled as pin 33 , I think it is called something MAP if you look on the pin out PDF . So , I do not know where it is . I can also try (gear cut sw reverse) setting for pin A31 this morning . That was good that you are checking both ECU's and comparing them. It would be great if that solves it. How do you like the fuelling between 3,000 and 4,000 ? It seems a little fluffy there on mine , especially when compared to the way it runs after 4,000 and up . Can you tell me what throttle stop percent you are for idle ? I am now set to 1.2% with the set screw .
 

Claudio

VIP MEMBER
Joined
Dec 3, 2018
Messages
85
Country flag
It is better not to go below 3000 rpm (my Guzzi under 3000 goes much better) I normally keep between 3000 and 4500/5000 and the engine is full and drives well, I like it very much.
on weekends I will test the CPU set for the side stand and the idle
 
Top