1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Another Isolastic Question

Discussion in 'Norton Commando Motorcycles (Classic)' started by Dommie Nator, Oct 21, 2018.

  1. Dommie Nator

    Dommie Nator VIP MEMBER

    Joined:
    Apr 2, 2013
    I've a retro fitted vernier isolastic set up on my 1972 Commando and the front rubbers have a split.
    They look like they "may" have split because they are a tight fit to the frame, but they are 12 years old so I'm not certain.
    Looking at replacements I'm not sure if I need the MK111 type as they were verniers or the pre Mk111.
    Any clues.
    TIA.
     

    Attached Files:

    Last edited: Oct 21, 2018
  2. bill

    bill

    Joined:
    Jun 1, 2003
    i don't like to run the rubber boots as they collect and hold water.
     
  3. 1up3down

    1up3down

    Joined:
    Jan 12, 2011
    i don't like to run the rubber boots as they collect and hold water.
    ----------------------------

    me neither, 30 years no boots now
     
  4. Torontonian

    Torontonian

    Joined:
    Dec 28, 2009
    True , you can have a spray can of Teflon PTFE lube handy and give a little shot now and then to clear the road dust out and provide better lubrication than grease IMO.
     
  5. batrider

    batrider

    Joined:
    Aug 9, 2008
    Worth the extra effort to put them on. The ones I got from AN last year had an extra fold, were softer, and fit tightly.
     
  6. L.A.B.

    L.A.B. Moderator VIP MEMBER

    Joined:
    Nov 20, 2004
    Dommie Nator likes this.
  7. Dommie Nator

    Dommie Nator VIP MEMBER

    Joined:
    Apr 2, 2013