Legendary/Speedhut speedo/tach

Discussion in 'Norton Commando Classic Motorcycles' started by drones76, Jan 10, 2018.

  1. drones76

    drones76

    Joined:
    Aug 1, 2011
    I purchased a combo unit a few weeks ago. After wiring it up(Negative Earth) on my '74 Commando, I took it for a spin. Seemed to work ok for about a few 10ths of a mile. Then the speedo and tach gauges froze. I stopped, powered off and rode it again. Similar results then it started going wacko. Mileage jumped up to 66,000 miles. The trip meter did similar. I contacted Legendary and sent it back. A month later it came back and I put it back on today. Started off fine for about a half a mile. Again the gauges locked up and it is not working again. They said they changed out the entire guts of the device. Has anyone else used these devices and have you had any issues. Checking to see if maybe I have missed. I will put a call into them tomorrow.

    Thanks
     
    Tags:
  2. blaisestation

    blaisestation

    Joined:
    Apr 10, 2008
    Hi,
    I have speed hut gauges on mine (both speedo and tacho)
    And have had no problems after 2 years of use .
    also alot of riding in the rain . + earth
     
  3. arch

    arch VIP MEMBER

    Joined:
    Jul 22, 2004
    Which gauge do you have?

    I am thinking about getting this one for a non norton project.

    https://www.dimecitycycles.com/4-in...es-electronic-gps-speedometer-tachometer.html

    I would be interested in knowing the outcome of your problems.
     
  4. Triton Thrasher

    Triton Thrasher

    Joined:
    Feb 10, 2009
    Electronic clocks?

    Is your ignition satisfactorily suppressed?
     
  5. drones76

    drones76

    Joined:
    Aug 1, 2011
  6. drones76

    drones76

    Joined:
    Aug 1, 2011
    Yes they are the same one in the link above. It may be an issue with suppression. I have a Pazon EI. What are the recommendations to suppress interference?
     
  7. RoadScholar

    RoadScholar VIP MEMBER

    Joined:
    Dec 28, 2008
    Find some NGK 5K ohm caps.
     
  8. Triton Thrasher

    Triton Thrasher

    Joined:
    Feb 10, 2009
    I had a GPS speedo that would stop working suddenly. 5 kohm plug caps fixed it.
     
  9. drones76

    drones76

    Joined:
    Aug 1, 2011
    Update. 5k ohm caps did in fact fix the issues. Thanks for the responses.
     
  10. splatt

    splatt

    Joined:
    Jul 14, 2008
    Did it require another repair or did the caps just fix every thing ?
     
  11. drones76

    drones76

    Joined:
    Aug 1, 2011
    I only went around the block with the 'new one' and it started to act erratic so I pulled into the driveway and disconnected it immediately. I did not want to take a chance of damaging it. So no new repair was necessary. I took it for about a 50 mile ride and all seems good. Seems to be very accurate and damn it looks good too.
     
  12. bill

    bill

    Joined:
    Jun 1, 2003
    another thing i like is the lighting in them.:)

     
  13. batrider

    batrider

    Joined:
    Aug 9, 2008
    Only one instrument cup then? Are you going to put something in the other cup or just have one?
     
  14. drones76

    drones76

    Joined:
    Aug 1, 2011
    I removed the old cups and purchased a bracket from Legendary. It had to be cut to fit. If the picture comes through you can see that the shell indicators are slightly blocked from view. Not a problem for the middle (blinkers) because there are left and right blinker indicators on the gauge. The left is the voltmeter LED and the right is the high beam indicator. I can shift my head to see those when needed.

    I do like the nice clean look of the new gauge. I got so frustrated dealing with the speedo gear in the back failing. When I got my one piece axle, Don (madass140) made a spacer that took up the space for that gear. I have also put a block on the tach port to do away with that issue. Funny thing is that both clocks worked fine when the it was the other parts that failed. I actually ran the bike for about 15,000 miles with a $10 schwinn magnetic induction speedo. Accurate upto 73 Mph.

    http://s1138.photobucket.com/user/Drones76/media/new gauge_zpswwupxhuo.jpg.html
     
  15. speedrattle

    speedrattle

    Joined:
    Dec 14, 2014
    i have a speedhut GPS tach that stops by itself, and won't easily cycle between the various displays. i always thought it was vibration.

    i run a magneto with solid copper wires and non-resistor plugs. maybe that's the problem.
     
  16. splatt

    splatt

    Joined:
    Jul 14, 2008
    I once had a little Datsun ute with solid ht leads and caps , couldn't set the timing cose the timing light would start flashing when ever you put it near the engine, also couldn't watch tv either
     

Share This Page

Loading...