Gearbox problemette

Status
Not open for further replies.
Joined
Oct 25, 2007
Messages
160
Country flag
:?: Hi Chaps - I have now just over 500 miles on my newly rebuilt Commando - upped to a 920 and gearbox rebuilt with new bearings etc. The bike runs beautifully and I'm dead chuffed with it but on the last couple of runs I've noticed that when using the bike on normal roads with plenty of gear-changing the gear selection is fine but after longish sustained runs on dual carriageways at 70-80 mph when I come to change down I lose gear selection from 3rd to 2nd and have to change back into top, 'chug along' in top for a moment or two and then selection returns perfectly and is then fine. As I say this only seems to happen after longish runs in top gear. I suspect the pawl spring setting but have any of you any ideas ?

P.S. The clutch is fine.
 
Joined
Jan 10, 2005
Messages
1,043
Country flag
Does sound like the pawl spring setting or lever not returning fully. Is it stiff when it does this? Not sure why only 3 to 2, would think it could happen in any gear if it's the spring.
 
Joined
Jan 27, 2008
Messages
1,607
Country flag
Just a guess here, but it could be the that a minor adjustment of the gearshift stop plate (part#064049) is needed. There is room for a little movement of this on its mounting bolts, and it may be that it is not allowing the ratchet spring (part#040038) to work properly. It may only show up in the 2-3 gear change, as you are transferring from one selector fork to another.
 
Status
Not open for further replies.
Top