Engine miss fire when warm

TT

Joined
Mar 7, 2005
Messages
53
After about 20 minutes of running my 850 MkIIa develops a missfire ... progressively getting worse. I think the missfire is on the left-hand cylinder.. but it is hard to tell when motoring down the road. Once the missfire starts the engine will not much past 3500 rpm.

Initially I thought it was the battery and charging system. I replaced the battery and checked the charging at 3000 rpm (14.5 volts). All looks OK. The bike starts OK - 3-4 kicks.

Something is geting warm and acting differently. Where should I be looking next?
 
Joined
Dec 5, 2005
Messages
90
Hi TT,
Well I have no magic answer, but first I would think u need to determin
either which side starts to misfire, or if it is not one particular side.
Trouble shooting is a process of elimination, take each step logically.

However a couple of quick checks.

Are the inlet manifolds tight?
Are the valve clearances correct?
Do the plugs look like they are oil fouled
Do they look like they are petrol fouled

When it is in misfire mode, pull the plugs and check spark on both plugs

Hopefully this will point you in the right direction


Regards Richard
 

Ron L

VIP MEMBER
Joined
Feb 27, 2004
Messages
3,116
Country flag
I believe what Ludwig means is change the coils from right to left and see if the misfire changes from one cylinder to the other. If so, then trace the wiring to that coil, including points if so equipped. If wiring seems good, then replace that coil. If not, then check the carburetor. Look for a misplaced needle clip. These have been known to pop off and cause a misfire.
 
Joined
Jun 17, 2006
Messages
22
Went through this on mine too! Do you have updated ignition? My experience led to the two wires coming from the Boyer ignition pickup. They were epoxied to the circuit board then tie wrapped to the board at the edge. The wires then travelled throught the case and up to the module under the fuel tank. Things were fine when the bike was cold but once warm she'd misfire something fierce. Drove me nuts for a couple days while I tracked down the problem. At the point the wires leave the pickup circuit board they start to vibrate and work harden. They eventually fail though they're held in place by the wires insulation. Thye may pin out just fine too with the multi-meter. When all is nicely warmed up the insulation becomes more pliable and gives greater flex to the break. Now the continuity starts to break down and the guess-work begins.
Hope this helps.
 
Top